centos6.5PHP启动脚本

安装完PHP后,自身有启动脚本,比如本人安装路径为:/usr/local/php

创新互联建站主要从事成都网站制作、做网站、外贸营销网站建设、网页设计、企业做网站、公司建网站等业务。立足成都服务沙河,十年网站建设经验,价格优惠、服务专业,欢迎来电咨询建站服务:18980820575

源码路径为:/usr/local/src/php-5.4.38

[root@lnmp ~]# cp /usr/local/src/php-5.4.38/sapi/fpm/init.d.php-fpm /etc/init.d/php-fpm

[root@lnmp ~]# chmod +x /etc/init.d/php-fpm #赋予执行权限

[root@lnmp ~]# chkconfig --add php-fpm

[root@lnmp ~]# service php-fpm status

php-fpm is stopped

[root@lnmp ~]# service php-fpm start

Starting php-fpm  done

本人由于之前是通过[root@lnmp ~]# /usr/local/php/sbin/php-fpm  已经开启php,此时如果报错

[root@lnmp ~]# /etc/init.d/php-fpm start

Starting php-fpm [23-Mar-2015 19:51:10] ERROR: unable to bind listening socket for address '127.0.0.1:9000': Address already in use (98)

[23-Mar-2015 19:51:10] ERROR: FPM initialization failed

 failed

[root@lnmp ~]# /etc/init.d/php-fpm stop

Gracefully shutting down php-fpm . done

[root@lnmp ~]# /etc/init.d/php-fpm start

Starting php-fpm  done


分享名称:centos6.5PHP启动脚本
文章位置:http://bzwzjz.com/article/pjegpo.html

其他资讯

Copyright © 2007-2020 广东宝晨空调科技有限公司 All Rights Reserved 粤ICP备2022107769号
友情链接: 成都网站建设 成都响应式网站建设 定制网站建设 成都网站设计 企业手机网站建设 网站设计 成都网站设计 泸州网站建设 成都网站制作 成都网站建设公司 高端网站设计 成都网站设计 企业网站建设公司 商城网站建设 LED网站设计方案 成都商城网站建设 成都网站建设公司 成都网站建设公司 达州网站设计 企业网站设计 专业网站设计 四川成都网站设计