Oracle12Cimpdp权限问题

很多时候,我们做小批数据迁移会用数据泵,但是12C我们要配置TNS指定PDB导入,然而大众的service我们都是通过集群利用srvctl来创建的。这时候preferred instances可能有多个值。而你的dmp文件如果不是通过共享存储进行挂载,那DMP就必须传到某个节点就行存放,进行相应的directory创建。

创新互联公司是一家专注于成都网站建设、成都网站设计与策划设计,南岸网站建设哪家好?创新互联公司做网站,专注于网站建设10多年,网设计领域的专业建站公司;建站业务涵盖:南岸等地区。南岸做网站价格咨询:13518219792

问题触发的场景,TNS如果此时是利用SCAN IP配置的,impdp username/passwd@TNS 这时候连接到节点的操作系统环境就不一定是dmp存放的环境。如果连到非dmp存放环境,这时候impdp就会报错。

问题解决办法:

1 修改连接串TNS,把SCAN IP 换成指定环境PUBLIC IP 或者VIP

2 如果preferred instances非双活双值配置,只有一个值,可以把相应的sevice relocate到指定节点。


分享标题:Oracle12Cimpdp权限问题
网页网址:http://bzwzjz.com/article/pggesd.html

其他资讯

Copyright © 2007-2020 广东宝晨空调科技有限公司 All Rights Reserved 粤ICP备2022107769号
友情链接: 品牌网站建设 定制网站设计 品牌网站建设 重庆网站建设 成都网站建设 重庆网站制作 响应式网站设计 成都企业网站设计 网站建设开发 手机网站设计 成都网站建设 达州网站设计 广安网站设计 高端网站设计 重庆网站制作 网站设计 成都商城网站建设 定制网站建设多少钱 成都网站建设 定制网站设计 高端品牌网站建设 成都定制网站建设