安装完Oracle11GR2之后,sqlplus/assysdba的时候报如下的错误

sqlplus: error while loading shared libraries: /u01/app/oracle/product/11.2.0/dbhome_1/lib/libclntsh.so.11.1: cannot restore segment prot after reloc: Permission denied

创新互联公司是一家从事企业网站建设、网站设计制作、网站建设、行业门户网站建设、网页设计制作的专业网络公司,拥有经验丰富的网站建设工程师和网页设计人员,具备各种规模与类型网站建设的实力,在网站建设领域树立了自己独特的设计风格。自公司成立以来曾独立设计制作的站点上1000家。

原因:安装 Oracle 之前配置Linux的时候忘记了SELINUX设置为display了。


方法: 以root身份  vi /etc/sysconfig/selinux  如下图:


# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - SELinux is fully disabled.
SELINUX=disabled
# SELINUXTYPE= type of policy in use. Possible values are:
#       targeted - Only targeted network daemons are protected.
#       strict - Full SELinux protection.
SELINUXTYPE=targeted

把上面的SELINUX=enforcing,改为SELINUX=disabled

然后重启即可。







网页题目:安装完Oracle11GR2之后,sqlplus/assysdba的时候报如下的错误
网站URL:http://bzwzjz.com/article/ipedpp.html

其他资讯

Copyright © 2007-2020 广东宝晨空调科技有限公司 All Rights Reserved 粤ICP备2022107769号
友情链接: 重庆网站建设 外贸网站设计方案 成都网站建设公司 成都网站建设 网站制作 响应式网站建设 手机网站制作 成都网站建设 网站建设推广 手机网站设计 温江网站设计 手机网站制作设计 网站制作 泸州网站建设 品牌网站建设 专业网站设计 企业网站设计 网站制作报价 成都网站制作 响应式网站设计 上市集团网站建设 网站制作