IIS6.0silverlight网站部署方法

下面我们以一个利用ASP.net2.0 webservice访问后台数据,通过Linq链接SQLserver2005数据库的silverlight网站为例,来说明这些注意事项。

从事内蒙古服务器托管,服务器租用,云主机,雅安服务器托管域名申请,CDN,网络代维等服务。

1、Windows2003安装iis6.0后,默认80端口没有访问权限,需要在Windows防火墙内打开TCP的80端口,否则外网无法链接本机Web服务。

2、注意更改您的silverlight的“web引用”的URL,使其与你发布的真实域名一致,否则silverlight无法正确调用您的WebService(因为silverlight不能跨域调用,所以WebService要与silverlight部署在同一个域内)。具体就是修改Reference.cs文件中URL字符串的赋值,然后重新编译整个工程。

3、在IIS中为您的silverlight目录建立一个新网站,端口“80”,IP地址“全部未分配”。

4、将“主目录”中“执行权限”参数设置为“纯脚本”,否则您的网站在访问时会报错“silverlight error 2252”。

5、注意修改您的数据库链接字符串,使其正确的指向您的sql2005数据库。

6、将网站的ASP.net版本设置为2.0

7、要保证“IUSE”用户和“NET SERVER”具有访问(读取和执行)你网站文件目录的权限。

好了,至此,您的silverlight网站就可以正常的被Internet访问了!


分享题目:IIS6.0silverlight网站部署方法
网站网址:http://bzwzjz.com/article/cojeocs.html
Copyright © 2007-2020 广东宝晨空调科技有限公司 All Rights Reserved 粤ICP备2022107769号
友情链接: 成都网站设计 成都模版网站建设 成都企业网站建设 成都商城网站制作 H5网站制作 成都网站设计 上市集团网站建设 网站建设推广 成都网站建设公司 高端网站设计 网站建设方案 成都网站建设 成都营销网站建设 网站建设 成都响应式网站建设 定制网站制作 成都网站制作 成都网站建设推广 成都做网站建设公司 定制网站建设多少钱 古蔺网站建设 手机网站设计